App EU degraded performance

Incident Report for Polly

Resolved

Some users on our EU platform experienced intermittent errors and slow responses on 28 July.
A combination of factors caused a loop where a server instance got overloaded by a background process in a short time span and got replaced, after which the same process overloaded the new instance. Because there are always multiple instances running at the same time, some users experienced issues while others were still able to use the application.

We have reallocated resources and made changes to our processes to prevent this scenario from happening again.
The platform has been stable since.
We apologise for the disruption.
Posted Jul 29, 2026 - 11:51 UTC

Monitoring

We have addressed the issue. Service should be restoring.
We will monitor the systems to make sure everything is running correctly.
Posted Jul 28, 2026 - 10:49 UTC

Investigating

The App in the EU region is experiencing a degraded performance. The issue is being investigated.
Posted Jul 28, 2026 - 10:05 UTC
This incident affected: App - EU.